Search Posts

Tunnel mode gre ip

Configuring a tunnel between 2 Cisco 2811 routers, done in Cisco Packet Tracer.

Partial config of RouterA

RouterA#show running-config 
!
!
interface Tunnel0
 ip address 192.168.10.1 255.255.255.0
 mtu 1476
 tunnel source Serial1/0
 tunnel destination 63.1.1.2
!
!
interface FastEthernet0/0
 ip address 10.0.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 63.1.1.1 255.255.255.252
 clock rate 2000000
!
ip route 0.0.0.0 0.0.0.0 192.168.10.2

Partial config of RouterB

RouterB#show running-config 
!
interface Tunnel0
 ip address 192.168.10.2 255.255.255.0
 mtu 1476
 tunnel source Serial1/0
 tunnel destination 63.1.1.1
!
!
interface FastEthernet0/0
 ip address 10.0.20.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 63.1.1.2 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 192.168.10.1 
!

Show ip route (RouterA)

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.2 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.10.0 is directly connected, FastEthernet0/0
     63.0.0.0/30 is subnetted, 1 subnets
C       63.1.1.0 is directly connected, Serial1/0
C    192.168.10.0/24 is directly connected, Tunnel0
S*   0.0.0.0/0 [1/0] via 192.168.10.2

Show ip route (RouterB)

RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.20.0 is directly connected, FastEthernet0/0
     63.0.0.0/30 is subnetted, 1 subnets
C       63.1.1.0 is directly connected, Serial1/0
C    192.168.10.0/24 is directly connected, Tunnel0
S*   0.0.0.0/0 [1/0] via 192.168.10.1

Ping check: RouterA can ping RouterB on 10.0.20.1

RouterA#ping 10.0.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms