Search Posts

VLAN on interface Cisco 2811


To add a VLAN on an interface and give it an IP address:

2811a#configure terminal
2811a(config)#interface fastEthernet 0/1.201
2811a(config-subif)#encapsulation dot1Q 201
2811a(config-subif)#ip address 192.168.11.1 255.255.255.0
2811a(config-subif)#end
2811a#


After performing above commands, the running-config concerning the interfaces will look like this:

…..
interface FastEthernet0/0
description Uplink to Firewall
ip address 172.16.0.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1.201
encapsulation dot1Q 201
ip address 192.168.11.1 255.255.255.0
…..


After adding some more VLANs, the running-config concerning the interfaces is:

…..
interface FastEthernet0/0
description Uplink to Firewall
ip address 172.16.0.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1.201
description 201-vlan
encapsulation dot1Q 201
ip address 192.168.11.1 255.255.255.0
!
interface FastEthernet0/1.202
description 202-vlan
encapsulation dot1Q 202
ip address 192.168.12.1 255.255.255.0
!
interface FastEthernet0/1.203
description 203-vlan
encapsulation dot1Q 203
ip address 192.168.13.1 255.255.255.0
!
interface FastEthernet0/1.204
description 204-vlan
encapsulation dot1Q 204
ip address 192.168.14.1 255.255.255.0
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
!
interface Vlan1
no ip address
…..