Search Posts

Cisco 2811 – Modules

A Cisco 2811 can have modules inserted. Here is a list of some of those modules:

NM-1E
NW-1E2W
NM-1FE-FX
NM-1FE-TX
NW-1FE2W
NM-2E2W
NM-2FE2W
NM-2W
NM-4A/S
NM-4E
NM-8A/S
NM-8AM
NM-ESW-161
HWIC-1GE-SFP
HWIC-2T
HWIC-4ESW
HWIC-8A
HWIC-AP-AG-B
WIC-1AM
WIC-1ENET
WIC-1T
WIC-2AM
WIC-2T

I was curious how those modules had effect on the running config concerning the interfaces. So in Packet Tracer, I took a moment to make an inventory of all those modules, with the interfaces section of the running config.

Modules: none
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown

Module: NM-1E
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Ethernet1/0
no ip address
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown

Module: NW-1E2W
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Ethernet1/0
no ip address
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown

Module: NM-1FE-FX
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
!
interface Vlan1
no ip address
shutdown

Module: NM-1FE-TX
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown

Module: NW-1FE2W
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown

Module: NM-2E2W
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Ethernet1/0
no ip address
duplex auto
speed auto
!
interface Ethernet1/1
no ip address
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown

Module: NM-2FE2W
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown

Module: NM-4A/S
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial1/0
no ip address
clock rate 2000000
!
interface Serial1/1
no ip address
clock rate 2000000
!
interface Serial1/2
no ip address
clock rate 2000000
!
interface Serial1/3
no ip address
clock rate 2000000
!
interface Vlan1
no ip address
shutdown

Module: NM-4E
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Ethernet1/0
no ip address
duplex auto
speed auto
!
interface Ethernet1/1
no ip address
duplex auto
speed auto
!
interface Ethernet1/2
no ip address
duplex auto
speed auto
!
interface Ethernet1/3
no ip address
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown

Module: NM-8A/S
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial1/0
no ip address
clock rate 2000000
!
interface Serial1/1
no ip address
clock rate 2000000
!
interface Serial1/2
no ip address
clock rate 2000000
!
interface Serial1/3
no ip address
clock rate 2000000
!
interface Serial1/4
no ip address
clock rate 2000000
!
interface Serial1/5
no ip address
clock rate 2000000
!
interface Serial1/6
no ip address
clock rate 2000000
!
interface Serial1/7
no ip address
clock rate 2000000
!
interface Vlan1
no ip address
shutdown

Module: NM-8AM
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Modem1/0
no ip address
!
interface Modem1/1
no ip address
!
interface Modem1/2
no ip address
!
interface Modem1/3
no ip address
!
interface Modem1/4
no ip address
!
interface Modem1/5
no ip address
!
interface Modem1/6
no ip address
!
interface Modem1/7
no ip address
!
interface Vlan1
no ip address
shutdown

Module: NM-ESW-161
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
switchport mode access
!
interface FastEthernet1/1
switchport mode access
!
interface FastEthernet1/2
switchport mode access
!
interface FastEthernet1/3
switchport mode access
!
interface FastEthernet1/4
switchport mode access
!
interface FastEthernet1/5
switchport mode access
!
interface FastEthernet1/6
switchport mode access
!
interface FastEthernet1/7
switchport mode access
!
interface FastEthernet1/8
switchport mode access
!
interface FastEthernet1/9
switchport mode access
!
interface FastEthernet1/10
switchport mode access
!
interface FastEthernet1/11
switchport mode access
!
interface FastEthernet1/12
switchport mode access
!
interface FastEthernet1/13
switchport mode access
!
interface FastEthernet1/14
switchport mode access
!
interface FastEthernet1/15
switchport mode access
!
interface Vlan1
no ip address
shutdown

Module: HWIC-1GE-SFP
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/3/0
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown

Module: HWIC-2T
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/3/0
no ip address
clock rate 2000000
!
interface Serial0/3/1
no ip address
clock rate 2000000
!
interface Vlan1
no ip address
shutdown

Module: HWIC-4ESW
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1/0
switchport mode access
!
interface FastEthernet0/1/1
switchport mode access
!
interface FastEthernet0/1/2
switchport mode access
!
interface FastEthernet0/1/3
switchport mode access
!
interface Vlan1
no ip address
shutdown

Module: HWIC-AP-AG-B
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Dot11Radio0/3/0
no ip address
speed 12.0 18.0 24.0 36.0 48.0 54.0 6.0 9.0 basic-1.0 basic-11.0 basic-2.0 basic-5.5
!
interface Dot11Radio0/3/1
no ip address
speed 18.0 36.0 48.0 54.0 9.0 basic-12.0 basic-24.0 basic-6.0
!
interface Vlan1
no ip address
shutdown

Module: WIC-1AM
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Modem0/3/0
no ip address
!
interface Vlan1
no ip address
shutdown

Module: WIC-1ENET
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Ethernet0/3/0
no ip address
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown

Module: WIC-1T
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/3/0
no ip address
clock rate 2000000
!
interface Vlan1
no ip address
shutdown

Module: WIC-2AM
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Modem0/3/0
no ip address
!
interface Modem0/3/1
no ip address
!
interface Vlan1
no ip address
shutdown

Module: WIC-2T
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/3/0
no ip address
clock rate 2000000
!
interface Serial0/3/1
no ip address
clock rate 2000000
!
interface Vlan1
no ip address
shutdown